Tuesday, December 30, 2008

The New Motherboard Has Not Solved My Problem


UPDATE 2: Googling the error code actually may have helped. I found this post on the Wisetechie Blog where the author had exactly the same problem. He was trying to install the same drivers I am, and it kept aborting, and he got the same error message. It turned out that the driver install checked for later versions. When it sees XP Service Pack 3, it thinks there's a newer version of itself already installed and aborts without giving the user the choice of continuing to install the patch. The problem is that SP3 does not contain an updated patch, so you're stuck. I'm going to try his solution as soon as I can figure out how to do it--he changed some registry value so that the installation program wouldn't see SP3. I was thinking of doing a System Restore back to before SP3 was released, then going and getting SP3 again once the audio driver installation is done.

UPDATE: OK, so I checked the BIOS/CMOS settings, and I have the onboard audio enabled. I unplugged the front panel leads just in case (found a forum post where that helped someone for some reason.) I then went to the FoxConn website and downloaded their updated audio driver--it's old enough that I think it's probably the same as the one on disk, but it was worth a shot. Same as the one on the disk, it goes through most of the installation and then gives me this error message. I have no idea what this means. I'm going to go Google "installation error message 0xE000027" (I'm assuming that a "0" is a zero.)


The good news is that the new mobo has not caused me any serious problems so far, and it appears to be allowing me to use things I couldn't before. For instance, both memory slots are functioning, so I have 2GB of RAM instead of 1.

The bad news is that I missed the Gun Nuts Radio Show tonight . . . again . . . because I still have no sound. I don't understand it. I just checked the System tab on the control panel, and under "Sounds and Audio Devices" it just says "No Audio Device." What gives? The thing's got to have some kind of audio installed. It's killing me.

I've got something I'm going to try, and then I'm fresh out of ideas. Anybody else got any?

13 comments:

suppa41 said...

Check your BIOS settings. It might be disabled in there. That would be the one thing that stands out if it doesn't show up in windows.

Don Gwinn said...

I just went in and disconnected two plugs that I think were in the wrong place--the front panel has a left and right output plug, and then each of those has a small spliced wire with another plug also labeled left and right output. So there were 2 marked "L_Out" and 2 marked "R_Out." When I pulled them off the old mobo, two were on pins marked as outputs, but two were on plugs marked as inputs. I just snipped the wires to the plugs on input pins (I've got nothing else to connect them to, and no other plugs to go on those pins.) When I restarted the machine, it prompted me with the "Found New Hardware" window, and it said it was installing "Media" with speaker icon. I was hopeful (but it's hard to tell what it's doing--it's like an oil light instead of a gauge.) It tried for awhile, and then gave up and informed me that it couldn't find the right software. I assumed the software should be on the disk that came with the motherboard.

I'll try to look at the BIOS next, thanks!

Geoff said...

Have you installed the drivers that came with the motherboard? They are usually on a CDRom that comes with.

Don Gwinn said...

I tried, but I just tried the audio driver again and it failed.

I went into the CMOS and it had an HD audio setting listed. The choices were Enabled, Disabled or Auto. It was set to Auto, but I went ahead and marked enabled. Didn't do anything. I unplugged all the plugs from the front panel just in case it would make a difference, but I guess my next stop is FoxConn's website to see if there's a better driver.

Joe Allen said...

It's almost certainly a driver issue.

Right click on "My Computer", select "properties" click on the "hardware" tab and then click on "device manager".

Anything with a yellow question mark has a driver issue - look under "sound, video and game controllers". There should be an entry for "somebrandname high definition audio"

If not, you'll need to run the Setup on the Driver disk, or download it from the Mobo mfg. website.

Don Gwinn said...

Joe, the only one listed with the yellow exclamation point was "Unknown Device." Inside it listed:
Type: Sound, Video and Game controllers.
Manufacturer: Unknown
Location: Location 65535 (Internal High Definition Audio Bus)

Under "Device Status" it said:

"This device is not configured correctly. (Code 1)
To reinstall the drivers for this device, click Reinstall Driver."

Clicking on "Reinstall Driver" doesn't seem to do anything at all. No installation or other change seems to take place.

chris said...

worst case scenario... you disable the realtek in the bios and install a sound blaster for $40...

Don Gwinn said...

I really think it's going to come to that. I hate to tie up a PCI slot, but I think I'm going to end up with no choice. I completely uninstalled Service Pack 3 and it still won't install the damn driver--still gives me the same error message.

It's a quarter past midnight here and I'm done for the night. Thanks, everybody.

Joe Allen said...

All these new-fangled "high definition" audio controllers won't install directly from drivers like everything else (makes unattended setup a pain) they actually have to be installed from a setup application and then all the useless autorun crap manually removed.

I'll drop you an email with my phone #, we can set up a remote assistance and get you squared away (unless I'm made of fail).

Joe

CGHill said...

After fighting my own battle with Realtek HD, I chose to tie up a PCI slot, since I did have two of them open. I pulled the Sound Blaster Live! from an old W98SE box and, mirabile dictu, Creative had XP drivers for it that worked.

smarterdeals.com said...

Online Shopping, Best computer price comparison shopping, Online computer price comparison shopping, Best compare computer price.

Wisetechie said...

Hi,

Can you tell me which part of my procedure you dont understand, will be glad to help, as you can see on the post a HUGE number of people have solved this problem already :)

Anonymous said...

酒店小姐
酒店兼職
禮服店
酒店經紀
酒店兼差
酒店打工
酒店上班
假日打工
台北酒店經紀
童裝批發
童裝批發
酒店喝酒
暑假打工
寒假打工
酒店
酒店經紀人
酒店現領